当前位置:首页 > 漏洞预警 > 正文

Apache Spark 远程代码执行漏洞(CVE-2020-9480)预警

发布时间:2020-06-24 20:20:09,来源:腾讯安全、中国信息通信研究院

       一、基本情况

Apache Spark是一个开源集群运算框架,专为大规模数据处理而设计的快速通用的计算引擎,Spark是UC Berkeley AMP lab (加州大学伯克利分校的AMP实验室)所开源的类Hadoop MapReduce的通用并行框架。

近日,监测发现Apache Spark官方发布了Apache Spark远程代码执行的风险通告,在Apache Spark 2.4.5以及更早版本中,独立资源管理器的主服务器可能被配置为需要通过共享密钥进行身份验证(spark.authenticate)。然而,由于Spark的认证机制存在缺陷,导致共享密钥认证失效。攻击者利用该漏洞,可在未授权的情况下,在主机上执行命令,造成远程代码执行。

       二、影响范围

Apache Spark:<=2.4.5

       三、处置建议

建议尽快升级到Spark 2.4.6 或者 Spark 3.0.0 版本,下载地址为:

 https://github.com/apache/spark/releases。

四、参考链接

(1)https://spark.apache.org/security.html#CVE-2020-9480