当前位置:首页 > 漏洞预警 > 正文

phpMyAdmin跨站点请求伪造漏洞(CVE-2019-12922)预警

发布时间:2019-09-21 11:38:05,来源:中国信息通信研究院

      一、基本情况

phpMyAdmin存在跨站请求伪造漏洞,CVE编号:CVE-2019-12922。攻击者可针对删除设置页面中任何服务器的phpMyAdmin用户触发CSRF攻击。

      二、攻击原理

phpMyAdmin是一个用PHP编写的免费软件工具,用于处理MySQL或MariaDB数据库服务器的管理。可使用phpMyAdmin执行大多数管理任务,包括创建数据库,运行查询和添加用户帐户。

phpMyAdmin中检测到跨站请求伪造,允许攻击者针对删除设置页面中任何服务器的phpMyAdmin用户触发CSRF攻击。 攻击者可以轻松创建包含想要代表用户执行的请求的假超链接,这样就可以避免由于错误使用HTTP方法而导致的CSRF攻击。

图片.png

      三、影响范围

受影响版本:

1)phpMyAdmin <= 4.9.0.1

2)phpMyAdmin = 5.0.0-alpha1

      四、处置建议

目前官方尚未修复此漏洞,请及时关注官方消息。

临时措施:在每次调用中实现令牌变量的验证,就像在其他phpMyAdmin请求中已经完成的那样。

      五、参考链接

1)https://thehackernews.com/2019/09/phpmyadmin-csrf-exploit.html

2)https://packetstormsecurity.com/files/154483/phpMyAdmin-4.9.0.1-Cross-Site-Request-Forgery.html