当前位置:首页 > 漏洞预警 > 正文

Ghostscript沙箱绕过 命令执行漏洞(CVE-2019-10216)预警

发布时间:2019-08-14 19:44:10,来源:中国信息通信研究院

      一、基本情况

Ghostscript存在命令执行漏洞,CVE编号: CVE-2019-10216。攻击者利用该漏洞可以直接绕过 ghostscript 的安全沙箱,读取任意文件或命令执行。

      二、漏洞描述

Artifex官方在ghostscriptf的master分支上提交合并Bug 701394的修复。旨在修复 CVE-2019-10216 漏洞。ghostscript应用广泛,ImageMagick、python-matplotlib、libmagick 等图像处理应用均有引用。

.buildfont1 该指令在执行的时候没有正确保护堆栈中的安全状态,导致-dSAFER安全沙箱状态被绕过。在此次针对修复的地方是为全部 .forceput 这一特殊指令增加 executeonly 限制。

      三、影响范围

commit 5b85ddd19a8420a1bd2d5529325be35d78e94234 均受到影响

ghostscript作为图像处理格式转换的底层应用。漏洞导致所有引用ghostscript的上游应用受到影响。涉及但不限于:

imagemagick

libmagick

graphicsmagick

gimp

python-matplotlib

texlive-core

texmacs

latex2html

latex2rtf

      四、处置建议

建议更新到(5b85ddd19a8420a1bd2d5529325be35d78e94234)之后的版本,或者直接重新拉取master分支进行更新

debain/redhat 等发行版均以更新上游package

redhat 5,6 均超出支持年限范围,请广大用户注意,及时进行手动修复更新

redhat :https://access.redhat.com/security/cve/cve-2019-10216

debain :https://security-tracker.debian.org/tracker/CVE-2019-10216

若无法更新可先尝试禁用使用gs解析ps文件

使用ImageMagick的,建议修改policy文件(默认位置:/etc/ImageMagick/policy.xml),在中加入以下(即禁用 PS、EPS、PDF、XPS coders、PCD):

1.png

但 taviso 提到 policy 是十分宽松的,可能会存在一些没有提及的格式存在绕过。

      五、参考链接

https://security-tracker.debian.org/tracker/CVE-2019-10216

https://www.openwall.com/lists/oss-security/2019/08/12/4