当前位置:首页 > 漏洞预警 > 正文

Cisco Application Policy Infrastructure Controller多个高危漏洞预警

发布时间:2021-08-27 15:36:35,来源:北京奇虎科技有限公司

      一、 基本情况

8月25日,Cisco发布安全公告,修复了Cisco Application Policy Infrastructure Controller (APIC)和Cisco Cloud Application Policy Infrastructure Controller (Cloud APIC)存在3个高危漏洞,相关漏洞CVE编号:CVE-2021-1577、CVE-2021-1578、CVE-2021-1579。攻击者可利用这些漏洞读写任意文件和实现权限提升。建议受影响用户及时更新至安全版本进行防护,做好资产自查以及预防工作,以免遭受黑客攻击。

      二、 漏洞等级

高危

      三、 漏洞描述

Cisco Application Policy Infrastructure Controller(APIC)是美国思科(Cisco)公司的一款自动化的基础架构部署和治理解决方案。

1.CVE-2021-1577:任意文件读写漏洞

该漏洞源于访问控制不当,攻击者可以通过使用特定API请求将文件上传到目标设备,成功利用该漏洞在目标设备上读取或写入任意文件。

2.CVE-2021-1578:权限提升漏洞

该漏洞源于策略默认设置不当,攻击者可以通过使用Cisco ACI Multi-Site Orchestrator (MSO)的非特权凭证向托管Cisco APIC或Cloud APIC设备发送特定API请求,成功利用该漏洞获取管理员凭证,从而提升到管理员权限。

3.CVE-2021-1579:权限提升漏洞

该漏洞源于基于角色的访问控制(RBAC)不足,具有管理员只读凭据的攻击者可以通过使用具有管理员写入凭证的应用程序发送特定API请求,成功利用该漏洞实现提升至管理员写入权限,在目标设备上读取或写入任意文件。

      四、 影响范围

1.CVE-2021-1577

Cisco APIC <=3.2,4.0,4.1,4.2,5.0,5.1

Cisco Cloud APIC <=3.2,4.0,4.1,4.2,5.0,5.1

2.CVE-2021-1578

Cisco APIC 5.0,5.1

Cisco Cloud APIC 5.0,5.1

3.CVE-2021-1579

Cisco APIC <=3.2,4.0,4.1,4.2,5.0,5.1,5.2

Cisco Cloud APIC <=3.2,4.0,4.1,4.2,5.0,5.1,5.2

      五、 安全建议

建议受影响用户尽快将Cisco APIC和Cisco Cloud APIC更新至以下安全版本:

Cisco APIC 3.2(10e),3.2(10f),4.2(6h),4.2(7l),5.1(3e),5.2(2f)

Cisco Cloud APIC 3.2(10e),3.2(10f),4.2(6h),4.2(7l),5.1(3e),5.2(2f)

      六、 参考链接

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-chvul-CKfGYBh8

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-pesc-pkmGK4J

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-frw-Nt3RYxR2